CVE-2012-2126

NameCVE-2012-2126
DescriptionRubyGems before 1.8.23 does not verify an SSL certificate, which allows remote attackers to modify a gem during installation via a man-in-the-middle attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs670228

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rubygems (PTS)sid3.2.0~rc.2-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rubygemssource(unstable)1.8.24-1670228

Search for package or bug name: Reporting problems