CVE-2012-2214

NameCVE-2012-2214
Descriptionproxy.c in libpurple in Pidgin before 2.10.4 does not properly handle canceled SOCKS5 connection attempts, which allows user-assisted remote authenticated users to cause a denial of service (application crash) via a sequence of XMPP file-transfer requests.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pidgin (PTS)jessie (security), jessie2.11.0-0+deb8u2fixed
stretch2.12.0-1fixed
bullseye, sid, buster2.13.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pidginsource(unstable)2.10.4-1low
pidginsourcesqueeze(unfixed)end-of-life

Notes

[squeeze] - pidgin <end-of-life> (Update not feasible, updated packages are provided through backports)
http://www.pidgin.im/news/security/?id=62

Search for package or bug name: Reporting problems