CVE-2012-2240

NameCVE-2012-2240
Descriptionscripts/dscverify.pl in devscripts before 2.12.3 allows remote attackers to execute arbitrary commands via unspecified vectors related to "arguments to external commands."
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2549-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
devscripts (PTS)squeeze, squeeze (security)2.10.69+squeeze4fixed
wheezy (security), wheezy2.12.6+deb7u2fixed
jessie2.15.3fixed
stretch, sid2.15.8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
devscriptssource(unstable)2.12.3high
devscriptssourcesqueeze2.10.69+squeeze4highDSA-2549-1

Search for package or bug name: Reporting problems