CVE-2012-2241

NameCVE-2012-2241
Descriptionscripts/dget.pl in devscripts before 2.12.3 allows remote attackers to delete arbitrary files via a crafted (1) .dsc or (2) .changes file, probably related to a NULL byte in a filename.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2549-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
devscripts (PTS)squeeze, squeeze (security)2.10.69+squeeze4fixed
wheezy, wheezy (security)2.12.6+deb7u2fixed
jessie2.15.3fixed
stretch2.15.5fixed
sid2.15.7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
devscriptssource(unstable)2.12.3medium
devscriptssourcesqueeze2.10.69+squeeze4mediumDSA-2549-1

Search for package or bug name: Reporting problems