CVE-2012-2242

NameCVE-2012-2242
Descriptionscripts/dget.pl in devscripts before 2.10.73 allows remote attackers to execute arbitrary commands via a crafted (1) .dsc or (2) .changes file, related to "arguments to external commands" that are not properly escaped, a different vulnerability than CVE-2012-2240.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2549-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
devscripts (PTS)squeeze (security), squeeze2.10.69+squeeze4fixed
wheezy, wheezy (security)2.12.6+deb7u2fixed
jessie, sid2.15.1fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
devscriptssource(unstable)2.12.3medium
devscriptssourcesqueeze2.10.69+squeeze4mediumDSA-2549-1

Search for package or bug name: Reporting problems