CVE-2012-2248

NameCVE-2012-2248
DescriptionAn issue was discovered in dhclient 4.3.1-6 due to an embedded path variable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs690532

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
isc-dhcp (PTS)jessie4.3.1-6+deb8u3fixed
jessie (security)4.3.1-6+deb8u4fixed
stretch (security), stretch4.3.5-3+deb9u1fixed
bullseye, sid, buster4.4.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
isc-dhcpsource(unstable)4.2.4-3690532
isc-dhcpsourcesqueeze(not affected)
isc-dhcpsourcewheezy4.2.2.dfsg.1-5+deb70u2

Notes

[squeeze] - isc-dhcp <not-affected> (CLIENT_PATH is not correctly defined)
Debian-specific

Search for package or bug name: Reporting problems