CVE-2012-2319

NameCVE-2012-2319
DescriptionMultiple buffer overflows in the hfsplus filesystem implementation in the Linux kernel before 3.3.5 allow local users to gain privileges via a crafted HFS plus filesystem, a related issue to CVE-2009-4020.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1fixed
jessie (security)3.16.59-1fixed
stretch4.9.144-3fixed
stretch (security)4.9.110-3+deb9u6fixed
buster4.19.16-1fixed
sid4.19.20-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)3.2.17-1low
linux-2.6source(unstable)(unfixed)high
linux-2.6sourcesqueeze2.6.32-46high

Search for package or bug name: Reporting problems