CVE-2012-2320

NameCVE-2012-2320
DescriptionConnMan before 0.85 does not ensure that netlink messages originate from the kernel, which allows remote attackers to bypass intended access restrictions and cause a denial of service via a crafted netlink message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs672989

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
connman (PTS)buster1.36-2.1~deb10u2fixed
buster (security)1.36-2.1~deb10u3fixed
bullseye1.36-2.2fixed
bullseye (security)1.36-2.2+deb11u1fixed
bookworm, sid1.41-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
connmansource(unstable)1.0-1low672989

Notes

[squeeze] - connman <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems