CVE-2012-2337

NameCVE-2012-2337
Descriptionsudo 1.6.x and 1.7.x before 1.7.9p1, and 1.8.x before 1.8.4p5, does not properly support configurations that use a netmask syntax, which allows local users to bypass intended command restrictions in opportunistic circumstances by executing a command on a host that has an IPv4 address.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2478-1
NVD severityhigh (attack range: local)
Debian Bugs673766
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sudo (PTS)squeeze, squeeze (security)1.7.4p4-2.squeeze.4fixed
squeeze (lts)1.7.4p4-2.squeeze.5fixed
wheezy1.8.5p2-1+nmu1fixed
wheezy (security)1.8.5p2-1+nmu2fixed
jessie1.8.10p3-1+deb8u2fixed
stretch, sid1.8.12-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sudosource(unstable)1.8.3p2-1.1high673766
sudosourcesqueeze1.7.4p4-2.squeeze.3highDSA-2478-1

Search for package or bug name: Reporting problems