CVE-2012-2389

NameCVE-2012-2389
Descriptionhostapd 0.7.3, and possibly other versions before 1.0, uses 0644 permissions for /etc/hostapd/hostapd.conf, which might allow local users to obtain sensitive information such as credentials.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)buster, buster (security)2:2.7+git20190128+0c1e29f-6+deb10u3fixed
bullseye2:2.9.0-21fixed
bookworm, sid2:2.10-9fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hostapdsource(unstable)(not affected)
wpasource(unstable)(not affected)

Notes

- hostapd <not-affected> (Debian package provides no default config file)
- wpa <not-affected> (Debian package provides no default config file)

Search for package or bug name: Reporting problems