CVE-2012-2404

NameCVE-2012-2404
Descriptionwp-comments-post.php in WordPress before 3.3.2 supports offsite redirects, which makes it easier for remote attackers to conduct cross-site scripting (XSS) attacks via unspecified vectors.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2470-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs670124
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)squeeze, squeeze (security)3.6.1+dfsg-1~deb6u4fixed
squeeze (lts)3.6.1+dfsg-1~deb6u6fixed
wheezy3.6.1+dfsg-1~deb7u5fixed
wheezy (security)3.6.1+dfsg-1~deb7u6fixed
jessie (security), jessie4.1+dfsg-1+deb8u1fixed
stretch, sid4.2.3+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)3.3.2+dfsg-1medium670124
wordpresssourcesqueeze3.3.2+dfsg-1~squeeze1mediumDSA-2470-1

Search for package or bug name: Reporting problems