CVE-2012-2652

NameCVE-2012-2652
DescriptionThe bdrv_open function in Qemu 1.0 does not properly handle the failure of the mkstemp function, when in snapshot node, which allows local users to overwrite or read arbitrary files via a symlink attack on an unspecified temporary file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2542-1, DSA-2545-1
NVD severitymedium (attack range: local)
Debian Bugs678280
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)squeeze, squeeze (security)0.12.5+dfsg-3squeeze4fixed
wheezy1.1.2+dfsg-6a+deb7u6fixed
wheezy (security)1.1.2+dfsg-6a+deb7u7fixed
stretch, jessie1:2.1+dfsg-11fixed
jessie (security)1:2.1+dfsg-12fixed
sid1:2.3+dfsg-4fixed
qemu-kvm (PTS)squeeze, squeeze (security)0.12.5+dfsg-5+squeeze11fixed
wheezy1.1.2+dfsg-6+deb7u6fixed
wheezy (security)1.1.2+dfsg-6+deb7u7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1.1.0+dfsg-1medium678280
qemusourcesqueeze0.12.5+dfsg-3squeeze2mediumDSA-2545-1
qemu-kvmsource(unstable)1.1.0+dfsg-1medium
qemu-kvmsourcesqueeze0.12.5+dfsg-5+squeeze9mediumDSA-2542-1

Search for package or bug name: Reporting problems