CVE-2012-2653

NameCVE-2012-2653
Descriptionarpwatch 2.1a15, as used by Red Hat, Debian, Fedora, and possibly others, does not properly drop supplementary groups, which might allow attackers to gain root privileges by leveraging other vulnerabilities in the daemon.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2481-1
NVD severityhigh (attack range: remote)
Debian Bugs674715
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
arpwatch (PTS)squeeze (security), squeeze2.1a15-1.1+squeeze1fixed
wheezy2.1a15-1.2fixed
sid, jessie2.1a15-1.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
arpwatchsource(unstable)2.1a15-1.2high674715
arpwatchsourcesqueeze2.1a15-1.1+squeeze1highDSA-2481-1

Notes

Debian build includes the vulnerable patch (in .diff.gz)

Search for package or bug name: Reporting problems