CVE-2012-2687

NameCVE-2012-2687
DescriptionMultiple cross-site scripting (XSS) vulnerabilities in the make_variant_list function in mod_negotiation.c in the mod_negotiation module in the Apache HTTP Server 2.4.x before 2.4.3, when the MultiViews option is enabled, allow remote attackers to inject arbitrary web script or HTML via a crafted filename that is not properly handled during construction of a variant list.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)stretch2.4.25-3+deb9u9fixed
stretch (security)2.4.25-3+deb9u11fixed
buster2.4.38-3+deb10u5fixed
buster (security)2.4.38-3+deb10u6fixed
bullseye2.4.48-3.1+deb11u1fixed
bullseye (security)2.4.51-1~deb11u1fixed
bookworm, sid2.4.51-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2sourcesqueeze2.2.16-6+squeeze8
apache2source(unstable)2.2.22-8low

Search for package or bug name: Reporting problems