CVE-2012-2690

NameCVE-2012-2690
Descriptionvirt-edit in libguestfs before 1.18.0 does not preserve the permissions from the original file and saves the new file with world-readable permissions when editing, which might allow local guest users to obtain sensitive information.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libguestfs (PTS)stretch1:1.34.6-2fixed
buster1:1.40.2-2fixed
bullseye1:1.44.0-2fixed
bookworm1:1.44.2-1fixed
sid1:1.44.2-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libguestfssource(unstable)1:1.18.0-1

Notes

Upstream patch https://www.redhat.com/archives/libguestfs/2012-February/msg00034.html
https://www.redhat.com/archives/libguestfs/2012-February/msg00033.html
https://bugzilla.redhat.com/show_bug.cgi?id=788642
https://www.openwall.com/lists/oss-security/2012/06/11/1
https://www.openwall.com/lists/oss-security/2012/06/11/5

Search for package or bug name: Reporting problems