CVE-2012-2743

NameCVE-2012-2743
DescriptionRevelation 0.4.13-2 and earlier does not iterate through SHA hashing algorithms for AES encryption, which makes it easier for context-dependent attackers to guess passwords via a brute force attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs633088

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
revelation (PTS)bullseye0.5.4-2fixed
bookworm, sid0.5.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
revelationsource(unstable)0.4.11-10low633088

Notes

[squeeze] - revelation <no-dsa> (Minor issue)
https://www.openwall.com/lists/oss-security/2012/06/18/1

Search for package or bug name: Reporting problems