CVE-2012-2751

NameCVE-2012-2751
DescriptionModSecurity before 2.6.6, when used with PHP, does not properly handle ...
SourceCVE (at NVD; oss-sec, OSVDB, EDB, Red Hat, Ubuntu, Gentoo, SuSE, more)
ReferencesDSA-2506-1
Debian Bugs678527, 678529
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libapache-mod-security (PTS)squeeze (security)2.5.12-1+squeeze2fixed
squeeze2.5.12-1+squeeze3fixed
modsecurity-apache (PTS)wheezy2.6.6-6+deb7u1fixed
jessie2.7.7-2fixed
sid2.8.0-1fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libapache-mod-securitysource(unstable)(unfixed)678529
libapache-mod-securitysourcesqueeze2.5.12-1+squeeze1DSA-2506-1
modsecurity-apachesource(unstable)2.6.6-1678527

Notes

http://www.openwall.com/lists/oss-security/2012/06/22/1
http://www.openwall.com/lists/oss-security/2012/06/22/2

Search for package or bug name: Reporting problems

Home - Testing Security Team - Debian Security - Source (SVN)