CVE-2012-2797

NameCVE-2012-2797
DescriptionUnspecified vulnerability in the decode_frame_mp3on4 function in libavcodec/mpegaudiodec.c in FFmpeg before 0.11 and Libav 0.8.x before 0.8.5 has unknown impact and attack vectors related to a calculation that prevents a frame from being "large enough."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs688847

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch7:3.2.14-1~deb9u1fixed
stretch (security)7:3.2.18-0+deb9u1fixed
buster7:4.1.8-0+deb10u1fixed
buster (security)7:4.1.9-0+deb10u1fixed
bullseye7:4.3.3-0+deb11u1fixed
bullseye (security)7:4.3.4-0+deb11u1fixed
bookworm, sid7:5.0.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsourcesqueeze(not affected)
ffmpegsource(unstable)7:2.4.1-1
libavsource(unstable)6:0.8.5-1688847

Notes

[squeeze] - ffmpeg <not-affected> (vulnerable code not present)
patch proposed: http://patches.libav.org/patch/32642/

Search for package or bug name: Reporting problems