CVE-2012-2803

NameCVE-2012-2803
DescriptionDouble free vulnerability in the mpeg_decode_frame function in libavcodec/mpeg12.c in FFmpeg before 0.11, and Libav 0.7.x before 0.7.7 and 0.8.x before 0.8.5, has unknown impact and attack vectors, related to resetting the data size value.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2624-1
NVD severityhigh (attack range: remote)
Debian Bugs688847, 688849
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)squeeze, squeeze (security)4:0.5.10-1fixed
squeeze (lts)4:0.5.10-1+deb6u1fixed
sid7:2.6.3-1fixed
libav (PTS)wheezy6:0.8.16-1fixed
wheezy (security)6:0.8.17-1fixed
jessie6:11.3-1fixed
stretch, sid6:11.3-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:2.4.1-1high
ffmpegsourcesqueeze4:0.5.10-1high688849
libavsource(unstable)6:0.8.5-1high688847

Search for package or bug name: Reporting problems