CVE-2012-2840

NameCVE-2012-2840
DescriptionOff-by-one error in the exif_convert_utf16_to_utf8 function in exif-entry.c in the EXIF Tag Parsing Library (aka libexif) before 0.6.21 allows remote attackers to cause a denial of service or possibly execute arbitrary code via crafted EXIF tags in an image.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2559-1
NVD severityhigh (attack range: remote)
Debian Bugs681454
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libexif (PTS)squeeze (security), squeeze0.6.19-1+squeeze1fixed
wheezy0.6.20-3fixed
jessie, sid0.6.21-2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libexifsource(unstable)0.6.20-3high681454
libexifsourcesqueeze0.6.19-1+squeeze1highDSA-2559-1

Notes

https://bugzilla.novell.com/show_bug.cgi?id=771229
http://seclists.org/oss-sec/2012/q3/74

Search for package or bug name: Reporting problems