CVE-2012-2870

NameCVE-2012-2870
Descriptionlibxslt 1.1.26 and earlier, as used in Google Chrome before 21.0.1180.89, does not properly manage memory, which might allow remote attackers to cause a denial of service (application crash) via a crafted XSLT expression that is not properly identified during XPath navigation, related to (1) the xsltCompileLocationPathPattern function in libxslt/pattern.c and (2) the xsltGenerateIdFunction function in libxslt/functions.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2555-1
NVD severitymedium
Debian Bugs689422

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)jessie (security), jessie57.0.2987.98-1~deb8u1fixed
stretch70.0.3538.110-1~deb9u1fixed
stretch (security)71.0.3578.80-1~deb9u1fixed
libxslt (PTS)jessie1.1.28-2+deb8u3fixed
jessie (security)1.1.28-2+deb8u6fixed
stretch1.1.29-2.1+deb9u1fixed
buster1.1.32-2.1~deb10u1fixed
bullseye, sid1.1.32-2.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersource(unstable)21.0.1180.89~r154005-1
chromium-browsersourcesqueeze(unfixed)end-of-life
libxsltsource(unstable)1.1.26-14689422
libxsltsourcesqueeze1.1.26-6+squeeze2DSA-2555-1

Search for package or bug name: Reporting problems