CVE-2012-2871

NameCVE-2012-2871
Descriptionlibxml2 2.9.0-rc1 and earlier, as used in Google Chrome before 21.0.1180.89, does not properly support a cast of an unspecified variable during handling of XSL transforms, which allows remote attackers to cause a denial of service or possibly have unknown other impact via a crafted document, related to the _xmlNs data structure in include/libxml/tree.h.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2555-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs689422
Debian/oldoldstablepackage chromium-browser is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)squeeze, squeeze (security)6.0.472.63~r59945-5+squeeze6vulnerable
wheezy (security), wheezy37.0.2062.120-1~deb7u1fixed
jessie43.0.2357.65-1~deb8u1fixed
jessie (security)44.0.2403.89-1~deb8u1fixed
stretch44.0.2403.107-1fixed
sid44.0.2403.157-1fixed
libxslt (PTS)squeeze, squeeze (security)1.1.26-6+squeeze3fixed
wheezy1.1.26-14.1fixed
jessie, stretch, sid1.1.28-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersource(unstable)21.0.1180.89~r154005-1medium
chromium-browsersourcesqueeze(unfixed)end-of-life
libxsltsource(unstable)1.1.26-14medium689422
libxsltsourcesqueeze1.1.26-6+squeeze2mediumDSA-2555-1

Search for package or bug name: Reporting problems