CVE-2012-2882

NameCVE-2012-2882
DescriptionFFmpeg, as used in Google Chrome before 22.0.1229.79, does not properly handle OGG containers, which allows remote attackers to cause a denial of service or possibly have unspecified other impact via unknown vectors, related to a "wild pointer" issue.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs694483

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)stretch70.0.3538.110-1~deb9u1fixed
stretch (security)71.0.3578.80-1~deb9u1fixed
ffmpeg (PTS)stretch7:3.2.14-1~deb9u1fixed
stretch (security)7:3.2.18-0+deb9u1fixed
buster7:4.1.8-0+deb10u1fixed
buster (security)7:4.1.9-0+deb10u1fixed
bullseye7:4.3.3-0+deb11u1fixed
bullseye (security)7:4.3.4-0+deb11u1fixed
bookworm, sid7:5.0.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersourcesqueeze(unfixed)end-of-life
chromium-browsersource(unstable)22.0.1229.94~r161065-1
ffmpegsource(unstable)(not affected)
libavsource(unstable)6:0.8.5-1694483

Notes

- ffmpeg <not-affected> (vulnerable code not present)
https://chromiumcodereview.appspot.com/10829204
fixed with http://git.libav.org/?p=libav.git;a=commitdiff;h=7751e4693dd10ec98c20fbd9887233b575034272

Search for package or bug name: Reporting problems