CVE-2012-3292

NameCVE-2012-3292
DescriptionThe GridFTP in Globus Toolkit (GT) before 5.2.2, when certain autoconf macros are defined, does not properly check the return value from the getpwnam_r function, which might allow remote attackers to gain privileges by logging in with a user that does not exist, which causes GridFTP to run as the last user in the password file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2523-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
globus-gridftp-server (PTS)squeeze, squeeze (security)3.23-1+squeeze1fixed
wheezy6.10-2fixed
jessie7.11-1fixed
stretch8.1-1fixed
sid8.7-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
globus-gridftp-serversource(unstable)6.5-1high
globus-gridftp-serversourcesqueeze3.23-1+squeeze1highDSA-2523-1

Search for package or bug name: Reporting problems