CVE-2012-3363

NameCVE-2012-3363
DescriptionZend_XmlRpc in Zend Framework 1.x before 1.11.12 and 1.12.x before 1.12.0 does not properly handle SimpleXMLElement classes, which allows remote attackers to read arbitrary files or create TCP connections via an external entity reference in a DOCTYPE element in an XML-RPC request, aka an XML external entity (XXE) injection attack.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2505-1
NVD severitymedium (attack range: remote)
Debian Bugs679215, 703870
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
moodle (PTS)squeeze1.9.9.dfsg2-2.1+squeeze4fixed
squeeze (security)1.9.9.dfsg2-2.1+squeeze3fixed
sid2.7.9+dfsg-1fixed
zendframework (PTS)squeeze, squeeze (security)1.10.6-1squeeze2fixed
squeeze (lts)1.10.6-1squeeze4fixed
wheezy1.11.13-1.1fixed
wheezy (security)1.11.13-1.1+deb7u2fixed
jessie (security), jessie1.12.9+dfsg-2+deb8u2fixed
stretch, sid1.12.13+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
moodlesource(unstable)2.5-1medium703870
moodlesourcesqueeze(not affected)
zendframeworksource(unstable)1.11.12-1medium679215
zendframeworksourcesqueeze1.10.6-1squeeze1mediumDSA-2505-1

Notes

[squeeze] - moodle <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems