CVE-2012-3366

NameCVE-2012-3366
DescriptionThe Trigger plugin in bcfg2 1.2.x before 1.2.3 allows remote attackers with root access to the client to execute arbitrary commands via shell metacharacters in the UUID field to the server process (bcfg2-server).
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2503-1
NVD severityhigh (attack range: remote)
Debian Bugs679272
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bcfg2 (PTS)squeeze, squeeze (security)1.0.1-3+squeeze2fixed
wheezy1.2.2-2fixed
jessie1.3.5-1fixed
stretch, sid1.3.5-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bcfg2source(unstable)1.2.2-2high679272
bcfg2sourcesqueeze1.0.1-3+squeeze2highDSA-2503-1

Search for package or bug name: Reporting problems