CVE-2012-3409

NameCVE-2012-3409
Descriptionecryptfs-utils: suid helper does not restrict mounting filesystems with nosuid,nodev which creates a possible privilege escalation
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs682220

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ecryptfs-utils (PTS)sid, stretch111-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ecryptfs-utilssource(unstable)99-1682220
ecryptfs-utilssourcesqueeze(not affected)

Notes

[squeeze] - ecryptfs-utils <not-affected> (home src/dest mountpoints hardcoded in that version)

Search for package or bug name: Reporting problems