CVE-2012-3435

NameCVE-2012-3435
DescriptionSQL injection vulnerability in frontends/php/popup_bitem.php in Zabbix 1.8.15rc1 and earlier, and 2.x before 2.0.2rc1, allows remote attackers to execute arbitrary SQL commands via the itemid parameter.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2539-1
NVD severityhigh (attack range: remote)
Debian Bugs683273
Debian/oldoldstablenot known to be vulnerable.
Debian/oldstablenot known to be vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zabbix (PTS)squeeze (security)1:1.8.2-1squeeze4fixed
jessie1:2.2.7+dfsg-2fixed
stretch, sid1:2.4.6+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zabbixsource(unstable)1:2.0.2+dfsg-1high683273
zabbixsourcesqueeze1:1.8.2-1squeeze4highDSA-2539-1

Notes

http://seclists.org/oss-sec/2012/q3/127

Search for package or bug name: Reporting problems