CVE-2012-3450

NameCVE-2012-3450
Descriptionpdo_sql_parser.re in the PDO extension in PHP before 5.3.14 and 5.4.x before 5.4.4 does not properly determine the end of the query string during parsing of prepared statements, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted parameter value.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2527-1
NVD severitylow (attack range: remote)
Debian Bugs683694
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)squeeze, squeeze (security)5.3.3-7+squeeze19fixed
squeeze (lts)5.3.3-7+squeeze25fixed
wheezy5.4.36-0+deb7u1fixed
wheezy (security)5.4.39-0+deb7u2fixed
stretch, sid, jessie5.6.7+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.4.4-1low683694
php5sourcesqueeze5.3.3-7+squeeze14lowDSA-2527-1

Notes

http://seclists.org/bugtraq/2012/Jun/60
https://bugs.php.net/bug.php?id=61755
http://www.openwall.com/lists/oss-security/2012/08/02/3
http://www.openwall.com/lists/oss-security/2012/08/02/7

Search for package or bug name: Reporting problems