CVE-2012-3465

NameCVE-2012-3465
DescriptionCross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/sanitize_helper.rb in the strip_tags helper in Ruby on Rails before 3.0.17, 3.1.x before 3.1.8, and 3.2.x before 3.2.8 allows remote attackers to inject arbitrary web script or HTML via malformed HTML markup.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2655-1
NVD severitymedium
Debian Bugs684454

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)jessie2:4.1.8-1+deb8u4fixed
jessie (security)2:4.1.8-1+deb8u5fixed
stretch2:4.2.7.1-1+deb9u1fixed
buster2:5.2.2.1+dfsg-1fixed
bullseye, sid2:5.2.3+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)2.3.14.1low
railssourcesqueeze2.3.5-1.2+squeeze8DSA-2655-1
ruby-actionpack-3.2source(unstable)3.2.6-4684454

Notes

Starting with 2.3.14.1 rails is a transition package

Search for package or bug name: Reporting problems