CVE-2012-3478

NameCVE-2012-3478
Descriptionrssh 2.3.3 and earlier allows local users to bypass intended restricted shell access via crafted environment variables in the command line.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2530-1
NVD severitylow (attack range: local)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rssh (PTS)squeeze, squeeze (security)2.3.2-13squeeze3fixed
wheezy2.3.3-6fixed
stretch, sid, jessie2.3.4-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rsshsource(unstable)2.3.3-5low
rsshsourcesqueeze2.3.2-13squeeze1lowDSA-2530-1

Search for package or bug name: Reporting problems