CVE-2012-3535

NameCVE-2012-3535
DescriptionHeap-based buffer overflow in OpenJPEG 1.5.0 and earlier allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a crafted JPEG2000 file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2629-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs685970
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openjpeg (PTS)squeeze, squeeze (security)1.3+dfsg-4+squeeze3fixed
wheezy, wheezy (security)1.3+dfsg-4.8fixed
jessie1:1.5.2-3fixed
stretch, sid1:1.5.2-3.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openjpegsource(unstable)1.3+dfsg-4.6medium685970
openjpegsourcesqueeze1.3+dfsg-4+squeeze1mediumDSA-2629-1

Search for package or bug name: Reporting problems