CVE-2012-3548

NameCVE-2012-3548
DescriptionThe dissect_drda function in epan/dissectors/packet-drda.c in Wireshark 1.6.x through 1.6.10 and 1.8.x through 1.8.2 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a small value for a certain length field in a capture file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs686225

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)stretch2.6.7-1~deb9u1fixed
stretch (security)2.6.20-0+deb9u1fixed
buster2.6.20-0+deb10u1fixed
bullseye, sid3.4.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksourcesqueeze(not affected)
wiresharksource(unstable)1.8.2-2unimportant686225

Notes

[squeeze] - wireshark <not-affected> (Vulnerable code not present)
Doesn't allow code injection
debian changelog contains CVE-2012-5239, but this was rejected in favour of CVE-2012-3548

Search for package or bug name: Reporting problems