CVE-2012-3826

NameCVE-2012-3826
DescriptionMultiple integer underflows in Wireshark 1.4.x before 1.4.13 and 1.6.x before 1.6.8 allow remote attackers to cause a denial of service (loop) via vectors related to the R3 dissector, a different vulnerability than CVE-2012-2392.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)stretch (security), stretch2.6.7-1~deb9u1fixed
buster2.6.8-1.1fixed
bullseye, sid3.2.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksourcesqueeze(not affected)
wiresharksource(unstable)1.6.8-1unimportant

Notes

[squeeze] - wireshark <not-affected> (vulnerable code appeared in 1.4/1.6)
not suitable for code injection
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=7125
leftover of CVE-2012-2392

Search for package or bug name: Reporting problems