CVE-2012-3868

NameCVE-2012-3868
DescriptionRace condition in the ns_client structure management in ISC BIND 9.9.x before 9.9.1-P2 allows remote attackers to cause a denial of service (memory consumption or process exit) via a large volume of TCP queries.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bind9 (PTS)stretch1:9.10.3.dfsg.P4-12.3+deb9u6fixed
stretch (security)1:9.10.3.dfsg.P4-12.3+deb9u8fixed
buster, buster (security)1:9.11.5.P4+dfsg-5.1+deb10u3fixed
bullseye, sid1:9.16.13-1fixed
isc-dhcp (PTS)stretch (security), stretch4.3.5-3+deb9u1fixed
buster4.4.1-2fixed
bullseye, sid4.4.1-2.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bind9source(unstable)(not affected)
isc-dhcpsource(unstable)(not affected)

Notes

https://kb.isc.org/article/AA-00730
- bind9 <not-affected> (Vulnerable code not present, only affects 9.9.x)
- isc-dhcp <not-affected> (embeds bind 9.8.x; this issue only affects 9.9.x)

Search for package or bug name: Reporting problems