CVE-2012-4048

NameCVE-2012-4048
DescriptionThe PPP dissector in Wireshark 1.4.x before 1.4.14, 1.6.x before 1.6.9, and 1.8.x before 1.8.1 allows remote attackers to cause a denial of service (invalid pointer dereference and application crash) via a crafted packet, as demonstrated by a usbmon dump.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2590-1
NVD severitylow (attack range: remote)
Debian Bugs680056
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)squeeze (security), squeeze1.2.11-6+squeeze14fixed
squeeze (lts)1.2.11-6+squeeze15fixed
wheezy1.8.2-5wheezy12fixed
wheezy (security)1.8.2-5wheezy14fixed
jessie1.12.1+g01b65bf-3fixed
sid1.12.1+g01b65bf-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.8.2-1low680056
wiresharksourcesqueeze1.2.11-6+squeeze8lowDSA-2590-1

Notes

http://www.wireshark.org/security/wnpa-sec-2012-11.html
http://www.openwall.com/lists/oss-security/2012/07/24/1
http://www.openwall.com/lists/oss-security/2012/07/24/2

Search for package or bug name: Reporting problems