CVE-2012-4188

NameCVE-2012-4188
DescriptionHeap-based buffer overflow in the Convolve3x3 function in Mozilla Firefox before 16.0, Firefox ESR 10.x before 10.0.8, Thunderbird before 16.0, Thunderbird ESR 10.x before 10.0.8, and SeaMonkey before 2.13 allows remote attackers to execute arbitrary code via unspecified vectors.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2565-1, DSA-2569-1, DSA-2572-1
NVD severityhigh (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceape (PTS)squeeze (security)2.0.11-17fixed
icedove (PTS)squeeze (security), squeeze3.0.11-1+squeeze15fixed
wheezy31.3.0-1~deb7u1fixed
wheezy (security)31.5.0-1~deb7u1fixed
jessie31.4.0-2fixed
sid31.5.0-1fixed
iceweasel (PTS)squeeze (security), squeeze3.5.16-20fixed
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)31.5.0esr-1~deb7u1fixed
jessie, sid31.5.0esr-1fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)2.7.9-1high
iceapesourcesqueeze2.0.11-16highDSA-2572-1
icedovesource(unstable)10.0.9-1high
icedovesourcesqueeze3.0.11-1+squeeze14highDSA-2569-1
iceweaselsource(unstable)10.0.8esr-1high
iceweaselsourcesqueeze3.5.16-19highDSA-2565-1

Search for package or bug name: Reporting problems