CVE-2012-4277

NameCVE-2012-4277
DescriptionCross-site scripting (XSS) vulnerability in the smarty_function_html_options_optoutput function in distribution/libs/plugins/function.html_options.php in Smarty before 3.1.8 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
smarty3 (PTS)stretch (security), stretch3.1.31+20161214.1.c7d42e4+selfpack1-2+deb9u1fixed
buster3.1.33+20180830.1.3a78a21f+selfpack1-1fixed
bullseye, sid3.1.34+20190228.1.c9f0de05+selfpack1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
smartysourcesqueeze(unfixed)end-of-life
smartysource(unstable)(unfixed)low
smarty3sourcesqueeze(unfixed)end-of-life
smarty3source(unstable)3.1.10-1

Notes

[squeeze] - smarty <end-of-life> (Unsupported in squeeze-lts)
[squeeze] - smarty3 <end-of-life> (Unsupported in squeeze-lts)

Search for package or bug name: Reporting problems