CVE-2012-4436

NameCVE-2012-4436
DescriptionBuffer overflow in the run_last_args function in client/fwknop.c in fwknop before 2.0.3, when processing --last, might allow local users to cause a denial of service (client crash) and possibly execute arbitrary code via many .fwknop.run arguments.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs688151

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fwknop (PTS)buster2.6.10-2fixed
bullseye2.6.10-12fixed
bookworm2.6.10-16fixed
sid, trixie2.6.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fwknopsourcesqueeze(not affected)
fwknopsourcewheezy2.0.0rc2-2+deb7u1
fwknopsource(unstable)2.0.3-1688151

Notes

[squeeze] - fwknop <not-affected> (Vulnerable code not present)
http://seclists.org/oss-sec/2012/q3/509
http://www.cipherdyne.org/cgi-bin/gitweb.cgi?p=fwknop.git;a=commitdiff;h=a60f05ad44e824f6230b22f8976399340cb535dc

Search for package or bug name: Reporting problems