CVE-2012-4437

NameCVE-2012-4437
DescriptionCross-site scripting (XSS) vulnerability in the SmartyException class in Smarty (aka smarty-php) before 3.1.12 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors that trigger a Smarty exception.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs688153, 702710

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
smarty3 (PTS)stretch (security), stretch3.1.31+20161214.1.c7d42e4+selfpack1-2+deb9u1fixed
buster3.1.33+20180830.1.3a78a21f+selfpack1-1fixed
bullseye, sid3.1.34+20190228.1.c9f0de05+selfpack1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
smartysourcesqueeze2.6.26-0.2+squeeze1
smartysource(unstable)(unfixed)702710
smarty3sourcesqueeze(unfixed)end-of-life
smarty3source(unstable)3.1.10-2688153

Notes

[squeeze] - smarty3 <end-of-life> (Unsupported in squeeze-lts)
http://www.openwall.com/lists/oss-security/2012/09/19/1
http://secunia.com/advisories/50589/
http://code.google.com/p/smarty-php/source/browse/trunk/distribution/change_log.txt
http://code.google.com/p/smarty-php/source/detail?r=4658
https://code.google.com/p/smarty-php/source/detail?r=4660

Search for package or bug name: Reporting problems