CVE-2012-4463

NameCVE-2012-4463
DescriptionMidnight Commander (mc) 4.8.5 does not properly handle the (1) MC_EXT_SELECTED or (2) MC_EXT_ONLYTAGGED environment variables when multiple files are selected, which allows user-assisted remote attackers to execute arbitrary commands via a crafted file name.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs689571

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mc (PTS)buster3:4.8.22-1fixed
bullseye3:4.8.26-1.1fixed
bookworm3:4.8.29-2fixed
sid, trixie3:4.8.31-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mcsource(unstable)3:4.8.8-1low689571

Notes

[wheezy] - mc <no-dsa> (Minor issue)
[squeeze] - mc <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems