CVE-2012-4504

NameCVE-2012-4504
DescriptionStack-based buffer overflow in the url::get_pac function in url.cpp in libproxy 0.4.x before 0.4.9 allows remote servers to have an unspecified impact via a large proxy.pac file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libproxy (PTS)stretch0.4.14-2fixed
stretch (security)0.4.14-2+deb9u2fixed
buster, buster (security)0.4.15-5+deb10u1fixed
bookworm, sid, bullseye0.4.17-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libproxysource(unstable)(not affected)

Notes

- libproxy <not-affected> (Vulnerable code not present)
0.4-only issue, fixed in newest upstream 0.4.9

Search for package or bug name: Reporting problems