CVE-2012-4510

NameCVE-2012-4510
Descriptioncups-pk-helper before 0.2.3 does not properly wrap the (1) cupsGetFile and (2) cupsPutFile function calls, which allows user-assisted remote attackers to read or overwrite sensitive files using CUPS resources.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2562-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups-pk-helper (PTS)squeeze (security), squeeze0.1.0-3fixed
wheezy0.2.3-3fixed
jessie, sid0.2.5-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cups-pk-helpersource(unstable)0.2.3-1medium
cups-pk-helpersourcesqueeze0.1.0-3mediumDSA-2562-1

Search for package or bug name: Reporting problems