CVE-2012-4516

NameCVE-2012-4516
Descriptionlibrdmacm 1.0.16, when ibacm.port is not specified, connects to port 6125, which allows remote attackers to specify the address resolution information for the application via a malicious ib_acm service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs690672

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
librdmacm (PTS)jessie1.0.19.1-1fixed
stretch1.1.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
librdmacmsource(unstable)1.0.16-1medium690672
librdmacmsourcesqueeze(not affected)
librdmacmsourcewheezy1.0.15-1+deb7u1medium

Notes

[squeeze] - librdmacm <not-affected> (Introduced in 1.0.12)

Search for package or bug name: Reporting problems