CVE-2012-4528

NameCVE-2012-4528
DescriptionThe mod_security2 module before 2.7.0 for the Apache HTTP Server allows remote attackers to bypass rules, and deliver arbitrary POST data to a PHP application, via a multipart request in which an invalid part precedes the crafted data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs691146

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
modsecurity-apache (PTS)buster, buster (security)2.9.3-1+deb10u1fixed
bullseye (security), bullseye2.9.3-3+deb11u1fixed
bookworm, sid2.9.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libapache-mod-securitysource(unstable)(unfixed)
modsecurity-apachesource(unstable)2.6.6-5691146

Notes

[squeeze] - libapache-mod-security <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems