DescriptionArgument injection vulnerability in in cgit 9.0.3 and earlier allows remote authenticated users with permissions to add files to execute arbitrary commands via the --plug-in argument to the highlight command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cgit (PTS)buster1.2.1+git2.18.0-1fixed
bookworm, sid1.2.3+git20221219.50.91f2590+git2.39.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cgitsource(unstable)(not affected)


- cgit <not-affected> (Fixed before the initial upload into the archive)

Search for package or bug name: Reporting problems