CVE-2012-4560

NameCVE-2012-4560
DescriptionMultiple buffer overflows in libssh before 0.5.3 allow remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libssh (PTS)jessie0.6.3-4+deb8u2fixed
jessie (security)0.6.3-4+deb8u3fixed
stretch0.7.3-2+deb9u2fixed
stretch (security)0.7.3-2+deb9u1fixed
buster0.8.7-1fixed
bullseye, sid0.9.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsshsource(unstable)0.5.3-1
libsshsourcesqueeze(not affected)

Notes

[squeeze] - libssh <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems