CVE-2012-4751

NameCVE-2012-4751
DescriptionCross-site scripting (XSS) vulnerability in Open Ticket Request System (OTRS) Help Desk 2.4.x before 2.4.15, 3.0.x before 3.0.17, and 3.1.x before 3.1.11 allows remote attackers to inject arbitrary web script or HTML via an e-mail message body with whitespace before a javascript: URL in the SRC attribute of an element, as demonstrated by an IFRAME element.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
otrs2 (PTS)squeeze, squeeze (security)2.4.9+dfsg1-3+squeeze5fixed
wheezy3.1.7+dfsg1-8+deb7u4fixed
wheezy (security)3.1.7+dfsg1-8+deb7u5fixed
jessie, stretch3.3.9-3fixed
sid4.0.7-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
otrs2source(unstable)3.1.7+dfsg1-6medium
otrs2sourcesqueeze2.4.9+dfsg1-3+squeeze4medium

Notes

DSA-2733-1

Search for package or bug name: Reporting problems