CVE-2012-4929

NameCVE-2012-4929
DescriptionThe TLS protocol 1.2 and earlier, as used in Mozilla Firefox, Google Chrome, Qt, and other products, can encrypt compressed data without properly obfuscating the length of the unencrypted data, which allows man-in-the-middle attackers to obtain plaintext HTTP headers by observing length differences during a series of guesses in which a string in an HTTP request potentially matches an unknown string in an HTTP header, aka a "CRIME" attack.
SourceCVE (at NVD; LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-0008-1, DLA-400-1, DSA-2579-1, DSA-2626-1, DSA-2627-1, DSA-3253-1
NVD severitylow (attack range: remote)
Debian Bugs689936, 700399, 700426, 727197, 728055

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)wheezy (security), wheezy2.2.22-13+deb7u6fixed
jessie2.4.10-10+deb8u4fixed
jessie (security)2.4.10-10+deb8u1fixed
stretch2.4.18-2fixed
sid2.4.20-1fixed
chromium-browser (PTS)wheezy (security), wheezy37.0.2062.120-1~deb7u1fixed
jessie49.0.2623.108-1~deb8u1fixed
jessie (security)50.0.2661.75-1~deb8u1fixed
stretch49.0.2623.108-1fixed
sid50.0.2661.94-1fixed
iceweasel (PTS)wheezy38.5.0esr-1~deb7u2fixed
wheezy (security)38.8.0esr-1~deb7u1fixed
jessie38.7.1esr-1~deb8u1fixed
jessie (security)38.8.0esr-1~deb8u1fixed
lighttpd (PTS)wheezy (security), wheezy1.4.31-4+deb7u4fixed
jessie1.4.35-4fixed
stretch, sid1.4.39-1fixed
nginx (PTS)wheezy (security), wheezy1.2.1-2.2+wheezy4fixed
jessie1.6.2-5fixed
jessie (security)1.6.2-5+deb8u1fixed
stretch1.9.10-1fixed
sid1.10.0-1fixed
openssl (PTS)wheezy (security), wheezy1.0.1e-2+deb7u20fixed
jessie (security), jessie1.0.1k-3+deb8u4fixed
stretch, sid1.0.2g-2fixed
pound (PTS)wheezy (security), wheezy2.6-2+deb7u1fixed
jessie (security), jessie2.6-6+deb8u1fixed
stretch, sid2.6-6.1fixed
qt4-x11 (PTS)wheezy4:4.8.2+dfsg-11fixed
jessie4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1fixed
stretch, sid4:4.8.7+dfsg-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2source(unstable)2.2.22-12low689936
apache2sourcesqueeze2.2.16-6+squeeze10lowDSA-2579-1
chromium-browsersource(unstable)22.0.1229.94~r161065-1low
chromium-browsersourcesqueeze(unfixed)end-of-life
iceweaselsource(unstable)(not affected)
lighttpdsource(unstable)1.4.30-1low700399
lighttpdsourcesqueeze1.4.28-2+squeeze1.2lowDSA-2626-1
nginxsource(unstable)1.2.1-2.2low700426
nginxsourcesqueeze0.7.67-3+squeeze3lowDSA-2627-1
opensslsource(unstable)1.0.1e-5low728055
opensslsourcesqueeze0.9.8o-4squeeze16low
opensslsourcewheezy1.0.1e-2+deb7u11low
poundsource(unstable)2.6-3low727197
poundsourcejessie2.6-6+deb8u1lowDSA-3253-1
poundsourcesqueeze2.6-1+deb6u1lowDLA-400-1
poundsourcewheezy2.6-2+deb7u1lowDSA-3253-1
qt4-x11source(unstable)4:4.8.2+dfsg-3low

Notes

- iceweasel <not-affected> (Firefox ESV not use TLS/SSL compression)
Chromium fix: https://chromiumcodereview.appspot.com/10825183/
[squeeze] - qt4-x11 <no-dsa> (Minor issue)
openssl redhat announcement https://rhn.redhat.com/errata/RHSA-2013-0587.html
openssl disables compression by default since dc5744cb78da6f2bcafeeefe22c604a51b52dfc5

Search for package or bug name: Reporting problems