CVE-2012-5534

NameCVE-2012-5534
DescriptionThe hook_process function in the plugin API for WeeChat 0.3.0 through 0.3.9.1 allows remote attackers to execute arbitrary commands via shell metacharacters in a command from a plugin, related to "shell expansion."
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2598-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
weechat (PTS)squeeze, squeeze (security)0.3.2-1+squeeze1fixed
wheezy0.3.8-1+deb7u1fixed
jessie1.0.1-1fixed
stretch1.1.1-1fixed
sid1.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
weechatsource(unstable)0.3.9.2-1high
weechatsourcesqueeze0.3.2-1+squeeze1highDSA-2598-1
weechatsourcewheezy0.3.8-1+deb7u1high

Search for package or bug name: Reporting problems